Nevada County RP - Server Maintenance – Incident details
Get updates
Email
Discord
Webhook
Get updates
All systems operational
Server Maintenance
Resolved
Major outage
Started 7 months ago
Lasted about 1 hour
Affected
1of1 Dedicated Server
Major outage from 2:41 PM to 3:29 PM
Nevada County Roleplay Main
Major outage from 2:41 PM to 3:29 PM
Updates
Resolved
August 16, 2025 at 3:29 PM
Resolved
August 16, 2025 at 3:29 PM
This incident has been resolved.
Investigating
August 16, 2025 at 2:41 PM
Investigating
August 16, 2025 at 2:41 PM
We are currently fixing some issues with the server.